Dutchie Ecom and Plus are experiencing degraded performance
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Jan 05, 2024 - 09:24 EST
Investigating
We are currently investigating this issue.
Posted Jan 05, 2024 - 08:55 EST
This incident affected: Dutchie Ecommerce (Dispensary Portal, Consumer Menus, Order Terminal, Dutchie Plus).