Dutchie POS Reporting Degraded
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Jan 17, 2024 - 12:39 EST
Investigating
We are currently investigating this issue.
Posted Jan 17, 2024 - 12:16 EST
This incident affected: Dutchie POS (Reporting).