Increased checkout failure rate on the LIVE server
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Mar 24, 2024 - 08:59 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2024 - 07:42 EDT
This incident affected: Dutchie POS (Register).