Google Cloud Impacted
Resolved

This issue has been resolved with Google Cloud and there should be no further impact on Dutchie services.

Fri, Jun 13, 2025, 12:30 AM
(2 days ago)
·
Affected components

No components marked as affected

Updates

Resolved

This issue has been resolved with Google Cloud and there should be no further impact on Dutchie services.

Fri, Jun 13, 2025, 12:30 AM

Investigating

We are aware of issues occurring within Google Cloud Platform (GCP). While NO Dutchie services are directly impacted, some partners may be experiencing issues.

Thu, Jun 12, 2025, 06:36 PM(5 hours earlier)
Powered by