Dutchie

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
DPOS Latency
Resolved·Degraded performance

All systems are fully operational.

Thu, Feb 5, 2026, 07:31 PM
(4 months ago)
·
Affected components
Feb 5, 2026, 06:07 PM
06:51 PM
Updates

Resolved

All systems are fully operational.

Thu, Feb 5, 2026, 07:31 PM

Monitoring

We believe the issue is fully resolved. The team is actively monitoring the systems.

Thu, Feb 5, 2026, 06:51 PM(40 minutes earlier)

Identified

The team has identified the issue and are working on the resolution. Most customers should be resolved at this time.

Thu, Feb 5, 2026, 06:36 PM(15 minutes earlier)

Investigating

We are currently investigating an issue affecting some Point of Sale operations. Our team is actively working to identify the cause and restore full functionality.

Thu, Feb 5, 2026, 06:07 PM(28 minutes earlier)