No components marked as affected
Resolved
BioTrack delivery functionality in Florida has successfully recovered.
Investigating
We are aware of an issue currently affecting delivery transactions for Florida-based dispensaries. Some operators may be experiencing errors when attempting to complete delivery compliance reporting through BioTrack/MMUR. We have engaged BioTrack directly and are actively working toward resolution.