No components marked as affected
Resolved
This has been resolved by CloudFlare.
Investigating
We are currently investigating reports of intermittent access issues affecting Dutchie POS and Back Office in specific regions. The issue appears to be related to a regional disruption with our network provider, Cloudflare. Our team is actively working with Cloudflare to identify and resolve the issue as quickly as possible. We will provide updates as more information becomes available.