No components marked as affected
Resolved
Cloudflare has confirmed this is resolved
Investigating
We are currently investigating reports of customers being unable to log into Dutchie POS on select servers. We have identified this as a regional internet outage affecting numerous online services, including Dutchie POS.