Resolved
We have resolved the issue. Thank you for your patience.
Investigating
Menus are now loading properly.
Investigating
We are currently investigating an issue where products may not be appearing on dispensary e-commerce menus.
Our engineering team is actively investigating the root cause. We will provide updates as our investigation progresses. We apologize for any disruption to your shopping experience.