Our image delivery provider has completed restoration of their service following an outage affecting image and photo loading across the Dutchie platform. Service is now fully operational. We appreciate your patience during this disruption and apologize for any inconvenience.
Resolved
Our image delivery provider has completed restoration of their service following an outage affecting image and photo loading across the Dutchie platform. Service is now fully operational. We appreciate your patience during this disruption and apologize for any inconvenience.
Investigating
We are currently investigating an issue affecting image and photo loading across the Dutchie platform. Some users may experience missing or slow-loading product images. Our team has identified this as stemming from a disruption with our image delivery provider, and we are actively monitoring their recovery. No data has been lost and core transaction functionality remains unaffected. We will provide updates as the situation develops.