Resolved
This incident has been resolved.
Monitoring
We have repaired the root cause and are monitoring for nominal performance.
Identified
We have identified the issue and have applied a remediation to restore service. We seeing early indications of service restoration.
Investigating
We are investing reports of sporadic latency on Dutchie E-Commerce and Dutchie Plus.