Resolved
This incident has been resolved.
Identified
BioTrack is aware of the issue and is working on implementing a fix
Investigating
We are currently working with the BioTrack Support team regarding errors observed by our Biotrack New Mexico customers.