Support Chatbot Issue
Resolved

This incident has been resolved.

Thu, Jan 25, 2024, 10:53 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, Jan 25, 2024, 10:53 PM

Identified

The issue has been identified and a fix is being implemented.

Thu, Jan 25, 2024, 09:37 PM(1 hour earlier)

Investigating

Support LiveChat is not connecting. We are working to resolve. To get in touch with Support, please call 866 838 8244. For additional support: https://support.dutchie.com/hc/en-us/articles/12809340978707-Contact-Dutchie-Support.

Thu, Jan 25, 2024, 04:28 PM(5 hours earlier)
Powered by