Intermittent issues with Text 2 Pay service
Resolved

This incident has been resolved.

Thu, Sep 28, 2023, 08:26 PM
(1 year ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Thu, Sep 28, 2023, 08:26 PM

Investigating

Our team is investigating issues with our Text 2 Pay service.

Thu, Sep 28, 2023, 07:53 PM(32 minutes earlier)
Powered by