Degraded performance for medical customers checkout in BioTrack Illinois
Resolved·Degraded performance

The date formatting issue was resolved by BioTrack.

Wed, May 14, 2025, 02:21 PM
(1 week ago)
·
Affected components
Updates

Resolved

The date formatting issue was resolved by BioTrack.

Wed, May 14, 2025, 02:21 PM

Monitoring

Customers have reported issue with checking out medical customers in Illinois due to degraded BioTrack functionality, which is currently incorrect / invalid information to our integration

Mon, May 5, 2025, 11:54 PM(1 week earlier)

Investigating

Customers have reported issue with checking out medical customers in Illinois due to degraded BioTrack functionality, which is currently incorrect / invalid information to our integration

Mon, May 5, 2025, 11:49 PM
Powered by