Resolved
This issue appears to be largely mitigated by BioTrack NM's team. Dutchie's Engineering team is observing normal response times from BioTrack NM at this time.
Monitoring
Dutchie Engineering has observed that customers in New Mexico are encountering slowness or delays when checking out guests, due to slow response times from BioTrack NM.
Dutchie Engineering is working with BioTrack NM.
BioTrack Case #00003700