Support Chatbot Issue
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Jan 25, 2024 - 17:53 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 25, 2024 - 16:37 EST
Investigating
Support LiveChat is not connecting. We are working to resolve. To get in touch with Support, please call 866 838 8244. For additional support: https://support.dutchie.com/hc/en-us/articles/12809340978707-Contact-Dutchie-Support.
Posted Jan 25, 2024 - 11:28 EST