POS Latency

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 15:31 EST

Investigating

Customers accessing Dutchie POS may experience degraded system performance. Our team is investigating.
Posted Feb 14, 2025 - 14:53 EST
This incident affected: Dutchie POS (Register, Backoffice).