Elevated Latency on Bluegate POS Environment
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Apr 21, 2024 - 13:06 EDT
Update
Back office and Register error rates have returned to nominal levels and we are observing normal traffic levels.

We will continue to closely monitor the performance of the bluegate cluster throughout the evening.
Posted Apr 20, 2024 - 19:14 EDT
Monitoring
We have finished restoring all register service and are observing consistent transaction volume for all Bluegate customers.

Back Office is accessible but has limited access to reporting. We expect to restore reporting service by 7pm EST.
Posted Apr 20, 2024 - 18:15 EDT
Update
We are continuing to work towards restoring full service - At the moment registers should be functional and we are seeing consistent transaction volume. We are diligently working to restore access to the back office system but do not have an ETA as of this posting.

If assistance is needed for back office functionality, please contact your Dutchie CSM or Dutchie Support.
Posted Apr 20, 2024 - 16:21 EDT
Update
We are continuing to see large amounts of traffic to the bluegate environment and are working to restore functionality beginning with the register.
Posted Apr 20, 2024 - 14:40 EDT
Update
We are continuing to reduce database contention on the Bluegate environment by disabling access to the back office. Register functionality has been restored but may continue to experience latency.
Posted Apr 20, 2024 - 14:03 EDT
Update
Dutchie engineers have deployed a change to reduce latency to the Bluegate environment. We are monitoring the impact and are seeing positive recovery signals.
Posted Apr 20, 2024 - 13:24 EDT
Update
We are continuing to investigate high levels of latency. Engineers are reducing load to the Bluegate server to restore transactional functionality.
Posted Apr 20, 2024 - 12:55 EDT
Identified
We are observing elevated latency on the Bluegate environment. We are investigating.
Posted Apr 20, 2024 - 12:36 EDT
This incident affected: Dutchie POS (Register, Backoffice).