Errors in METRC MI
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Sep 05, 2023 - 18:12 EDT
Monitoring
Errors in Metrc MI markets have been decreasing, we are continuing to monitor the situation with Metrc. Ticket number: 02010387
Posted Sep 05, 2023 - 16:08 EDT
Investigating
We have been made aware of customers experiencing errors in Metrc MI markets. We have contacted Metrc Support for assistance. - Metrc Ticket 02010387
Posted Sep 05, 2023 - 15:24 EDT
This incident affected: Dutchie POS (Register) and Traceability & Compliance (Metrc).