Merrco Dispensaries are currently experiencing checkout issues
Resolved·Degraded performance

This incident has been resolved.

Wed, Nov 20, 2024, 02:58 AM
(7 months ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Nov 20, 2024, 02:58 AM

Monitoring

The 3rd party provider has implemented a fix that appears to have restored service. Engineering continues to monitor the situation.

Wed, Nov 20, 2024, 02:42 AM(16 minutes earlier)

Identified

We have identified an issue with a 3rd party provider and are awaiting resolution. Users attempting to checkout with a credit card in Canada may experience service disruption. Please select a different payment option or pay in store.

Wed, Nov 20, 2024, 02:07 AM(34 minutes earlier)

Investigating

We are currently investigating this issue.

Wed, Nov 20, 2024, 01:44 AM(22 minutes earlier)
Powered by