Dutchie POS BI Tools Reports Data Delays

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 18:26 EST

Monitoring

We are seeing improvements in delays but some customers may continue to see stale data in BI Tools reports and dashboards in back office. We are continuing to monitor the situation and working to resolve this issue.
Posted Feb 14, 2025 - 13:58 EST

Investigating

We have a identified an issue where BI Tools reports and dashboards in Dutchie POS back office are showing stale data. We are working to resolve this issue.
Posted Feb 14, 2025 - 12:10 EST
This incident affected: Dutchie POS (Reporting).