POS Degraded - west.pos.dutchie.com
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Jan 30, 2024 - 02:59 EST
Investigating
Customers accessing Dutchie POS via west.pos.dutchie.com may experience degraded system performance. Our team is investigating.
Posted Jan 30, 2024 - 02:39 EST
This incident affected: Dutchie POS (Register).