IL Traceability Degraded
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted May 08, 2024 - 13:31 EDT
Monitoring
Biotrack has communicated that the issue has been resolved. Engineers continue to monitor.
Posted May 08, 2024 - 13:23 EDT
Investigating
We are experiencing degraded performance with Biotrack in Illinois that may impact POS checkout performance. Support has reached out to BioTrack and will continue to monitor the situation.
Posted May 08, 2024 - 12:28 EDT
This incident affected: Traceability & Compliance (BioTrack).