Metrc experiencing delivery errors across multiple states
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted May 30, 2023 - 12:20 EDT
Investigating
Customers in multiple states are receiving "The delivery cannot be found in METRC. Please try marking the order ready for delivery again in Delivery Options." when attempting to process deliveries. Metrc is aware of the issue and we are working closely with them. The Metrc ticket number of this incident is 1825897
Posted May 26, 2023 - 20:23 EDT
This incident affected: Dutchie POS (Compliance) and Traceability & Compliance (Metrc).