Errors in METRC MO (Missouri)
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted May 29, 2024 - 20:02 EDT
Monitoring
We are currently working with the Metrc Support team regarding errors observed by our Metrc MO (Missouri) customers. Metrc Ticket 02171748
Posted May 29, 2024 - 12:34 EDT
This incident affected: Traceability & Compliance (Metrc).