Text 2 Pay Service is Currently Down
Incident Report for Dutchie
Resolved
Please contact support@dutchie.com or your CSM with any questions
Posted Nov 08, 2023 - 10:22 EST
Identified
We have identified the issue and are investigating possible solutions with our partners at Rethink.
Posted Nov 07, 2023 - 18:14 EST
Update
We are working with our partners at Rethink to triage the issue.
Posted Nov 07, 2023 - 17:03 EST
Investigating
We are currently investigating this issue.
Posted Nov 07, 2023 - 16:34 EST