Metrc latency in Oregon

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Mar 06, 2025 - 17:42 EST

Investigating

We are observing increased latency and timeouts in METRC for Oregon. The METRC ticket number is 02259309.
Posted Mar 06, 2025 - 11:43 EST
This incident affected: Dutchie POS (Register).