Veriscan Service Outage
Resolved

This incident has been resolved.

Tue, Apr 8, 2025, 07:49 PM
(1 month ago)
·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Tue, Apr 8, 2025, 07:49 PM

Investigating

We have been informed that Veriscan www.idscan.net (ID scanning system) is having a service outage. There is no ETA at this time. We are in communication with them and will follow up as we receive information.

Tue, Apr 8, 2025, 06:46 PM(1 hour earlier)
Powered by