Errors in OMC Traceability System in Minnesota

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted 7 days ago. Mar 27, 2025 - 16:41 EDT

Investigating

We are currently working with the OMC Support team regarding errors observed by our OMC Minnesota customers.
Posted 7 days ago. Mar 27, 2025 - 16:23 EDT
This incident affected: Traceability & Compliance (MN OMC).