Dutchie Storefront/Sub-domain menus are degraded
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Dec 12, 2023 - 17:41 EST
Investigating
We are currently investigating this issue.
Posted Dec 12, 2023 - 17:14 EST
This incident affected: Dutchie Ecommerce (Consumer Menus).