BioTrack Illinois Outage
Incident Report for Dutchie
Resolved
Biotrack has confirmed that the issue should be resolved, and transactions no longer appear to be timing out; functionality should be back to normal at this time.
Posted Nov 10, 2024 - 22:21 EST
Investigating
We are observing increased latency and timeouts in Biotrack Illinois. We have contacted BioTrack and are working with them to help identify the issue.
Posted Nov 10, 2024 - 19:19 EST
This incident affected: Dutchie POS (Register, Backoffice).