Resolved
This incident has been resolved.
Monitoring
Dutchie has rolled out mitigations to resume SMS delivery. We will continue to monitor the situation.
Investigating
Dutchie is currently experiencing text messaging delivery issues. We will update this page as we have more information.