Errors in METRC Michigan

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 10:50 EDT

Investigating

We are currently working with the Metrc Support team regarding errors observed by our Metrc Michigan customers. Metrc Ticket - 02263040
Posted Mar 20, 2025 - 09:25 EDT
This incident affected: Traceability & Compliance (Metrc).