Biotrack IL Timeout Errors Preventing Checkout
Resolved·Degraded performance

This incident has been resolved.

Sun, Nov 17, 2024, 09:40 PM
(6 months ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Sun, Nov 17, 2024, 09:40 PM

Identified

We are continuing to work on a fix for this issue.

Sun, Nov 17, 2024, 09:31 PM

Identified

The issue has been identified and a fix is being implemented.

Sun, Nov 17, 2024, 09:03 PM(28 minutes earlier)

Investigating

We are continuing to investigate this issue.

Sun, Nov 17, 2024, 08:30 PM(32 minutes earlier)

Investigating

We are continuing to investigate this issue.

Sun, Nov 17, 2024, 08:05 PM(25 minutes earlier)

Investigating

Biotrack Illinois is experiencing an elevated error rate, which is particularly impacting checkout functionality.

Sun, Nov 17, 2024, 08:03 PM
Powered by