Delivery Issues with METRC Integration
Incident Report for Dutchie
Resolved
This incident has been resolved. Delivery operations are fully functional.
Posted Nov 02, 2023 - 08:00 EDT
Investigating
Experiencing an issue with METRC integrations CA Deliveries.

Delivery services may be impacted. Working to resolve this issue immediately.
Posted Nov 01, 2023 - 21:18 EDT
This incident affected: Dutchie POS (Register) and Traceability & Compliance (Metrc).