Errors in METRC Michigan

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 10:53 EDT

Monitoring

Performance is trending in the right direction. Engineers continue to monitor the situation.
Posted Mar 26, 2025 - 09:55 EDT

Update

We are continuing to investigate this issue.
Posted Mar 26, 2025 - 09:37 EDT

Investigating

We are currently working with the Metrc Support team regarding errors observed by our Metrc Michigan customers. Metrc Case Number - 02264589
Posted Mar 26, 2025 - 09:24 EDT
This incident affected: Traceability & Compliance (Metrc).