Metrc experiencing timeouts and errors in all states
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted May 25, 2023 - 19:50 EDT
Investigating
Ticket 1825897 has been opened with Metrc. We have been notified by metrc that users are seeing timeout and error responses when attempting integrated activity. Metrc has acknowledged an issue on their side that is being addressed.
Posted May 25, 2023 - 11:12 EDT
This incident affected: Traceability & Compliance (Metrc).