BioTrack NM Latency
Resolved·Degraded performance

This incident has been resolved.

Thu, Sep 14, 2023, 11:52 PM
(1 year ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Thu, Sep 14, 2023, 11:52 PM

Investigating

We are currently tracking an issue with BioTrack NM latency. We have reached out to their Support Team to report the issue and we are awaiting further updates from the team there.

Thu, Sep 14, 2023, 11:50 PM
Powered by