Errors in BioTrack New Mexico
Resolved·Degraded performance

This incident has been resolved.

Wed, Jun 5, 2024, 10:12 PM
(11 months ago)
·
Affected components
Updates

Resolved

This incident has been resolved.

Wed, Jun 5, 2024, 10:12 PM

Identified

BioTrack is aware of the issue and is working on implementing a fix

Wed, Jun 5, 2024, 08:49 PM(1 hour earlier)

Investigating

We are currently working with the BioTrack Support team regarding errors observed by our Biotrack New Mexico customers.

Wed, Jun 5, 2024, 07:59 PM(49 minutes earlier)
Powered by