Errors in Metrc MO
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted Sep 07, 2023 - 11:23 EDT
Update
We are continuing to investigate this issue.
Posted Sep 07, 2023 - 10:47 EDT
Investigating
We have been made aware of customers experiencing errors in Metrc MO markets. We have contacted Metrc Support for assistance. - Metrc Ticket 02011370
Posted Sep 07, 2023 - 09:41 EDT
This incident affected: Dutchie POS (Compliance) and Traceability & Compliance (Metrc).