NY Traceability MCDMS is degraded
Incident Report for Dutchie
Resolved
This incident has been resolved.
Posted May 14, 2024 - 08:37 EDT
Monitoring
MCDMS has communicated that the issue has been resolved. Engineers continue to monitor.
Posted May 14, 2024 - 08:27 EDT
Investigating
We are currently monitoring degraded performance from NY MCDMS.
Posted May 14, 2024 - 08:13 EDT
This incident affected: Traceability & Compliance (NYC MCDMS).