Metrc Latency in Oklahoma

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 00:34 EST

Investigating

We are observing increased latency and timeouts in METRC for Oklahoma. The METRC ticket number is 02259604.
Posted Mar 06, 2025 - 22:55 EST
This incident affected: Dutchie POS (Register).