BioTrack Florida Outage

Incident Report for Dutchie

Resolved

This incident has been resolved.
Posted Apr 14, 2025 - 11:19 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 14, 2025 - 10:05 EDT

Investigating

BioTrack Florida is aware of the current issues and is actively investigating.
Posted Apr 14, 2025 - 09:08 EDT
This incident affected: Traceability & Compliance (BioTrack).