BioTrack New Mexico issues
Incident Report for Dutchie
Resolved
BioTrack has resolved the issues in New Mexico. All systems are functional.
Posted Mar 10, 2023 - 18:43 EST
Investigating
We are aware of issues with BioTrack New Mexico. We have reached out and will update as we get more information.
Posted Mar 10, 2023 - 17:56 EST
This incident affected: Traceability & Compliance (BioTrack) and Dutchie POS (Compliance).