No components marked as affected
Resolved
This incident has been resolved.
Monitoring
A fix has been implemented and we are monitoring the results.
Investigating
We are experiencing increased latency from our Hypur integration exceeding 30 seconds, leading to slow checkouts for customers using this payment option. Our team is currently investigating.